Multiple Vulnerabilities Found in Satellite Internet Access Terminal Let Hackers Intercept the GPS Traffic
October 11, 2019
Mo Moin (2461 articles)
Share

Multiple Vulnerabilities Found in Satellite Internet Access Terminal Let Hackers Intercept the GPS Traffic

Researchers from CERT/CC discovered multiple vulnerabilities in Satcom terminal Cobham EXPLORER 710 that affects both firmware and device.

The vulnerabilities allow hackers to perform several attacks such as intercept the traffic, remotely execute the command, implant and hide a backdoor, DoS Attack, exfiltrate the sensitive data and more

Cobham EXPLORER 710 is a satellite telecommunication terminal, the device provides you internet access through satellite and various feature including the fastest on-demand video streaming via satellite.

The Terminal used in various sectors including space systems, Commercial aerospace, Maritime SATCOM, Land and Air defense for Military, Fighter jets and more.

EXPLORER 710 is also a highly sophisticated communication tool that provides IP streaming rates of 1 Mbps or even higher via an ethernet connection.

Cobham EXPLORER 710 provides communication interfaces including 2 x Ethernet, USB, WLAN 802.11 a/b/g, Digital I/O, Bluetooth and also the terminal is capable of providing Internet, Email, Phone, VoIP, FTP, FoIP (Fax), SMS Text, Video Streaming via satellite.

There are 6 severe vulnerabilities found in Cobham EXPLORER 710, and all the vulnerabilities affect the firmware version 1.07.

CVE-2019-9529 – Authentication Failure
CVE-2019-9530 – Unrestricted Directory Access
CVE-2019-9531 – Authentication Failure
CVE-2019-9532 – Plan text Data Exchange
CVE-2019-9533 – Default Login Credentials
CVE-2019-9534 – Validate Failure
CVE-2019-9529 – Authentication Failure
An authentication failure vulnerability resides in the web application portal let unauthenticated attackers gain the portal access and perform any changes to the device.

CVE-2019-9530 – Unrestricted Directory Access
An unrestricted directory Access vulnerability found in webroot directory that contains no access restrictions and is allows local attackers to perform read, write and download any files from the Web root directory.

CVE-2019-9531 – Authentication Failure
Another Authentication failure vulnerability found in Cobham EXPLORER 710 Satcom terminal web application portal allows attackers to perform unauthenticated access to port 5454 on the device.

” This could allow an unauthenticated, remote attacker to connect to this port via Telnet and execute 86 Attention (AT) commands, including some that provide unauthenticated, shell-like access to the device.”

CVE-2019-9532 – Plan text Data Exchange
A vulnerability found in web application portal that passing the login password in cleartext that allows a local attacker to intercept the traffic and gain complete control of the portal.

CVE-2019-9533 – Default Login Credentials
The device contains the root password that is the same for all versions of firmware up to and including v1.08.

By having the default root password, devices are highly vulnerable to attackers who could possibly reverse-engineer the password in all the available versions to gain complete unauthenticated device access.

CVE-2019-9534 – Validate Failure
Due to validation failure, the device does not validate its firmware image, and the Development scripts left in the firmware can be used to upload a custom firmware image that the device runs.

Along with the above-mentioned flaws, researchers also discovered the missing of important security headers, which are highly dangerous for the device and it is vulnerable to cross-site scripting and clickjacking.

The CERT/CC said that they are currently unaware of a practical solution to these problems.

This post Multiple Vulnerabilities Found in Satellite Internet Access Terminal Let Hackers Intercept the GPS Traffic originally appeared on GB Hackers.

Read More